天天看点

【斯特林公式】N!的k进制位数

题目描述

我们知道n!=n*(n-1)*(n-2)*…*2*1。

那么给定一个n,n!是几位数呢。

更困难的,n!的k进制数有多少位呢。

输入

第一行是一个数T(1≤T≤50000),代表T组测试数据。

每一组测试数据占一行,有两个整数n(0 ≤ n ≤ 10^6),k(2≤k≤1000)。

输出

对于每组测试数据,输出n!k进制数的位数。

样例输入

2
3 10
3 2
      

样例输出

1
3
      

最后除以log(k)

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#include<cmath>
const double Pi=acos(-1.0);
const double e=exp(1.0);
/*斯特林公式N!=sqrt(2*Pi*N)*(N/e)N次方,Pi=acos(-1.0) e=exp( -1.0 )*/
int main(){
int t;
scanf("%d",&t);
double n,k;
while(t--){
	scanf("%lf%lf",&n,&k);
	if(n==0||n==1)
	printf("1\n");
	else if(n==2&&k==2)
    printf("2\n");
	else
	printf("%.0lf\n",floor((log(sqrt(2*1.0*Pi*n))+n*log(n*1.0/e))/(log(k)))+1);
}
	return 0;
}