FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48150 Accepted Submission(s): 16204
Problem Description FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
Author CHEN, Yue
//一开始看不懂题意,其实就是有n个猫住的小房子;n列数据即可理解为价位表,
//如几个猫食可以兑换几个豆子,用老鼠持有的猫食总数m从兑换率最高的房间开始依次兑换:贪心思想;
#include<iostream>
#include<algorithm>
using namespace std;
struct food
{
int beans;
int catfood;
double rate;
};
bool cmp(const food a,const food b)//对结构中某一数据进行排序;
{
return a.rate>b.rate;
}
int main()
{
int m,n,i;
double s;
while(cin>>m>>n)
{
if(m==-1&&n==-1)
break;
food *p=new food[n];
s=0;
for(i=0;i<n;i++)
{
cin>>p[i].beans>>p[i].catfood;
p[i].rate=(double)p[i].beans/p[i].catfood;
}
sort(p,p+n,cmp);
for(i=0;i<n;i++)
{
if(p[i].catfood<m)//所需猫食小于原持有则执行
{
m-=p[i].catfood;
s+=p[i].beans;
}
else
{
s+=p[i].rate*m;
break;//不要忘记break否则 循环继续,继续兑换豆子;
}
}
printf("%.3lf\n",s);
delete []p;
}
return 0;
}