天天看点

HDU 5775 Bubble Sort

Problem Description

P is a permutation of the integers from 1 to N(index starting from 1).

Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)

for(int j=N,t;j>i;—j)

if(P[j-1] > P[j])

t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits

T <= 20

1 <= N <= 100000

N is larger than 10000 in only one case. 

Output

For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input

2

3

3 1 2

3

1 2 3

Sample Output

Hint

In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)

the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3

In second case, the array has already in increasing order. So the answer of every number is 0.

很明显,每个数字右移的位数为右边比其小的数字的个数,左边最远的位置是当前位置或者数字最终的位置。

#include<set>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
const int INF = 0x7FFFFFFF;
int T, n, a[N], f[N], b[N], cas = 0;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        rep(i, 1, n) scanf("%d", &a[i]), f[i] = 0;
        per(i, n, 1)
        {
            b[a[i]] = i;
            for (int j = a[i]; j; j -= low(j)) b[a[i]] += f[j];
            for (int j = a[i]; j <= n; j += low(j)) f[j]++;
            b[a[i]] -= min(i, a[i]);
        }
        printf("Case #%d: ", ++cas);
        rep(i, 1, n) printf("%d%s", b[i], i == n ? "\n" : " ");
    }
    return 0;
}