1049: 字元圖形5-星号梯形
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 56 Solved: 48
原題連結
Description
輸入一個整數列印字元圖形 N=3輸出
□□×××
□×××××
×××××××
N=5
□□□□×××
□□□×××××
□□×××××××
□×××××××××
×××××××××××
Input
一個整數(0<N<10)
Output
一個字元圖形
Sample Input
3
Sample Output
***
*****
*******
HINT
□表示一個空格,"×"表示一個'*'
Source
#include<iostream>
using namespace std;
main()
{
int N;
cin>>N;
for(int i=1;i<=N;i++)
{
for(int j=0;j<N-i;j++)
{cout<<' ';}
for(int k=1;k<=2*i+1;k++)
{cout<<'*';}
cout<<endl;
}
}