天天看点

HDU 2051 10进制转化为2进制Bitset

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13417    Accepted Submission(s): 10255

Problem Description Give you a number on base ten,you should output it on base two.(0 < n < 1000)  

Input For each case there is a postive number n on base ten, end of file.  

Output For each case output a number on base two.  

Sample Input

1
2
3
        

Sample Output

1
10
11
        

Author 8600 && xhd  

Source 校庆杯Warm Up

代码:

# include<cstdio>
# include<iostream>

using namespace std;

void f( int x )
{
    if ( x==0 )
        return;
    f(x/2);
    int a = x%2;
    cout<<a;
}


int main(void)
{
    int n;
    while ( cin>>n )
    {
        if ( n==0 )
            cout<<"0"<<endl;
        f(n);
        cout<<endl;
    }


    return 0;
}