給大家推薦個靠譜的公衆号程式員探索之路,大家一起加油
素數判定
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 93448 Accepted Submission(s): 32888
Problem Description
對于表達式n^2+n+41,當n在(x,y)範圍内取整數值時(包括x,y)(-39<=x<y<=50),判定該表達式的值是否都為素數。
Input
輸入資料有多組,每組占一行,由兩個整數x,y組成,當x=0,y=0時,表示輸入結束,該行不做處理。
Output
對于每個給定範圍内的取值,如果表達式的值都為素數,則輸出"OK",否則請輸出“Sorry”,每組輸出占一行。
Sample Input
0 1 0 0
Sample Output
OK
Author
lcy
Source
C語言程式設計練習(二)
#include<stdio.h>
#include<math.h>
int pan(int m)
{
int k=m/2;
int i;
for(i=2;i<m;i++)
{
if(m%i==0) return 0;
}
return 1;
}
int main()
{
int x,y,n,flag;
while(1)
{
flag=0;
scanf("%d %d",&x,&y);
if(x==0&&y==0) break;
for(int j=x+1;j<y;j++)
{
n=j*j+j+41;
if(pan(n)==0)
{
flag=1;
break;
}
}
if(flag==1) printf("Sorry\n");
else printf("OK\n");
}
return 0;
}