Jungle Roads
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5454 Accepted Submission(s): 3935
Problem Description
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30
題意:
給出一些編号為大寫字母的城市,A 表示第一個城市,依次往後,最多26個城市,某些城市之間有很多道路相連,現在給出所有的城市,以及他們之間的道路的數量長度,讓你從這些道路中找到最短的路程,讓所有的城市都連通,輸出最短的道路長度。
比較簡單的最小生成樹模闆題目,隻需要控制好格式,其他地方問題不大,克魯斯卡爾算法比較适合這一類的題目,注意條件的控制。
這個題的輸入特别坑,不知道為什麼。在poj和南陽上,如果用getchar來吸收換行,那麼會顯示re,沒辦法了,隻能在輸入前面加空格來吸收了....
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int n,per[30],cnt,kase;
struct road
{
int a,b;
int len;
}x[105];
void init()//初始化
{
for(int i=1;i<=n;++i)
{
per[i]=i;
}
}
int find(int x)//查找
{
int r=x;
while(r!=per[r])
{
r=per[r];
}
int i=x,j;
while(i!=r)
{
j=per[i];per[i]=r;i=j;
}
return r;
}
void join(int a,int b)//合并
{
int fx=find(a),fy=find(b);
if(fx!=fy)
{
per[fy]=fx;
++cnt;kase=1;//統計邊數
}
}
int cmp(road a,road b)
{
return a.len<b.len;
}
int main()
{
int i,j,m,a,c;char u,v;
while(~scanf("%d",&n),n)
{
init();c=cnt=0;
for(i=0;i<n-1;++i)
{
scanf(" %c %d",&u,&m);
for(j=0;j<m;++j)
{
scanf(" %c %d",&v,&a);
x[c].a=u-'A'+1;x[c].b=v-'A'+1;x[c].len=a;//把對應的字母轉化為數字存下來
++c;//累加道路數量
}
getchar();
}
sort(x,x+c,cmp);//排序
int sum=0;
for(i=0;i<c&&cnt<n-1;++i)
{
kase=0;
join(x[i].a,x[i].b);
if(kase)//是否加入成功
{
sum+=x[i].len;
}
}
printf("%d\n",sum);
}
return 0;
}