天天看點

1013 -- 分糖果

分糖果

Time Limit:1000MS  Memory Limit:65536K

Total Submit:401 Accepted:197

Description

暑假了小明在家裡閑着無事,就幫着自己的弟弟輔導功課。一天,弟弟問了小明這樣一個問題:老師手上有n個糖果,要獎勵班上的優秀同學。為公平起見,被獎勵的同學每人的糖果數是一樣的。假如獎勵前5名同學,則還多1枚糖果;假如獎勵前7個同學,則還剩3枚糖果。問老師手上最少有幾枚糖果?小明很快幫弟弟的問題解決了。但喜歡程式設計的小明心想,類似這樣的問題,程式設計求解不是更快嗎?!請你乘小明還在思考的時候,捷足先登,送出解答代碼。

Input

輸入包含多組測試資料。每組資料包含4個整數,分别為a1,b1,a2,b2,表示老師獎勵前a1個同學,還剩b1枚糖果沒分出去,或者獎勵前a1個同學,還剩b1枚糖果沒分出去。(a1>b1>0,a2>b2>0)且(a1≠a2,a1,a2<1000)。

Output

對于每組測試資料,輸出一個正整數,即老師手上最少應該有的糖果數。

Sample Input

5  1  7  3
3  2  11  3      

Sample Output

31
14      

Source

[email protected]

using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1013 {
        class Program {
            static int gcd(int a, int b) {
                return b == 0 ? a : gcd(b, a % b);
            }
            static int lcm(int a, int b) {
                return a / gcd(a, b) * b;
            }
            static void Main(string[] args) {
                string s;
                while ((s = Console.ReadLine()) != null) {
                    string[] a = s.Split();
                    int a1 = int.Parse(a[0]), b1 = int.Parse(a[1]), a2 = int.Parse(a[2]), b2 = int.Parse(a[3]);
                    for (int i = 1; i <= lcm(a1, a2); i++)//實際這樣寫我感覺是不合理的,但是AC了,怎麼能求最小公倍數呢,i don't know!
                        if (i % a1 == b1 && i % a2 == b2) { Console.WriteLine(i); break; }
                }
            }
        }
    }