三角形
Time Limit:1000MS Memory Limit:65536K
Total Submit:431 Accepted:217
Description
輸入三角形三邊長度a,b,c(均為正整數)判斷能否為直角三角形的三個邊長。如果可以則輸出"yes",如果不能則輸出"no",如果根本無法組成三角形則輸出 "not a triangle"
Input
輸入三角形三邊長度a,b,c(均為正整數)
Output
判斷能否為直角三角形的三個邊長。如果可以則輸出"yes",如果不能則輸出"no",如果根本無法組成三角形則輸出 "not a triangle"
Sample Input
3 5 4
Sample Output
yes
Source
lrj程式入門
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1106 {
class Program {
static void Main(string[] args) {
int[] a = new int[3];
string[] values = Console.ReadLine().Split(' ');
a[0] = int.Parse(values[0]); a[1] = int.Parse(values[1]); a[2] = int.Parse(values[2]);
Array.Sort(a);
if (a[0] * a[0] + a[1] * a[1] == a[2] * a[2])
Console.WriteLine("yes");
else if (a[0] + a[1] <= a[2] || a[2] - a[1] >= a[0])
Console.WriteLine("not a triangle");
else
Console.WriteLine("no");
}
}
}