水仙花數
Time Limit:1000MS Memory Limit:65536K
Total Submit:831 Accepted:336
Description
請判斷一個數是不是水仙花數。
其中水仙花數定義各個位數立方和等于它本身的三位數。
Input
有多組測試資料,每組測試資料以包含一個整數n(100<=n<1000)
輸入0表示程式輸入結束。
Output
如果n是水仙花數就輸出Yes
否則輸出No
Sample Input
153
154
0
Sample Output
Yes
No
Source
C語言基礎
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1032 {
class Program {
static bool jtahstu(int n) {
int x = n % 10, y = n / 10 % 10, z = n / 100;
if (x * x * x + y * y * y + z * z * z == n) return true;
return false;
}
static void Main(string[] args) {
string sb;
while ((sb = Console.ReadLine()) != null) {
int n = int.Parse(sb);
if (n == 0) break;
if (jtahstu(n))
Console.WriteLine("Yes");
else
Console.WriteLine("No");
}
}
}
}