找子串
Time Limit:1000MS Memory Limit:65536K
Total Submit:170 Accepted:61
Description
給定原子串和目标子串,要你求得目标子串在原子串當中出現的次數。
Input
多組測試資料,每組測試資料第一行是原子串,第二行是目标子串
子串長度不會超過100.
Output
輸出目标子串在原子串當中出現的次數。
Sample Input
abc123abc
abc
aabcCdeAbcAbcdeccde
cde
Sample Output
2
2
Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1084 {
class Program {
static void Main(string[] args) {
string s;
while ((s = Console.ReadLine()) != null) {
int count = 0;
string b = Console.ReadLine();
for (int i = 0; i < s.Length - b.Length + 1; i++) {
string sb = s.Substring(i, b.Length);
if (sb.Equals(b))
count++;
}
Console.WriteLine(count);
}
}
}
}