天天看點

1168 -- 奮鬥的小蝸牛

奮鬥的小蝸牛

Time Limit:1000MS  Memory Limit:65536K

Total Submit:139 Accepted:89

Description

傳說中能站在金字塔頂的隻有兩種動物,一種是鷹,一種是蝸牛。一隻小蝸牛聽了這個傳說後,大受鼓舞,立志要爬上金字塔。為了實作自己的夢想,蝸牛找到了老鷹,老鷹告訴它金字塔高H米,小蝸牛知道一個白天自己能向上爬10米,但由于晚上要休息,自己會下滑5米。它想知道自己在第幾天能站在金字塔頂,它想讓你幫他寫個程式幫助它。

Input

第一行有一個整數t,表示t組測試資料。

第二行一個整數H(0 < H < 10^9)代表金字塔的高度。

Output

輸出一個整數n表示小蝸牛第n天站在金字塔頂上

Sample Input

2
1
5      

Sample Output

1
1      

Source

using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1168 {
        class Program {
            static void Main(string[] args) {
                int n = int.Parse(Console.ReadLine());
                while (n-- > 0) {
                    int h = int.Parse(Console.ReadLine());
                    if (h <= 10) Console.WriteLine("1");
                    else {
                        if (h % 5 == 0)
                            Console.WriteLine(h / 5 - 1);
                        else
                            Console.WriteLine(h / 5);
                    }
                }
            }
        }
    }