一種排序
Time Limit:1000MS Memory Limit:65536K
Total Submit:33 Accepted:24
Description
現在有很多長方形,每一個長方形都有一個編号,這個編号可以重複;還知道這個長方形的寬和長,編号、長、寬都是整數;現在要求按照一下方式排序(預設排序規則都是從小到大);
1.按照編号從小到大排序
2.對于編号相等的長方形,按照長方形的長排序;
3.如果編号和長都相同,按照長方形的寬排序;
4.如果編号、長、寬都相同,就隻保留一個長方形用于排序,删除多餘的長方形;最後排好序按照指定格式顯示所有的長方形;
Input
第一行有一個整數 0每一組第一行有一個整數 0接下來的m行,每一行有三個數 ,第一個數表示長方形的編号,
第二個和第三個數值大的表示長,數值小的表示寬,相等
說明這是一個正方形(資料約定長寬與編号都小于10000);
Output
順序輸出每組資料的所有符合條件的長方形的 編号 長 寬
Sample Input
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
Sample Output
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1
Source
nyist
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK093 {
class Program {
struct Rectangle {
public int len , wid , bian;
}
public class MyComparer : IComparer<Rectangle> {
int IComparer<Rectangle>.Compare(Rectangle x , Rectangle y) {
if (x.bian == y.bian) {
if (x.len == y.len)
return x.wid < y.wid ? -1 : 1;
return x.len < y.len ? -1 : 1;
}
return x.bian < y.bian ? -1 : 1;
}
}
static void Main(string[] args) {
int n = int.Parse(Console.ReadLine());
while (n-- > 0) {
int m = int.Parse(Console.ReadLine());
Rectangle[] a = new Rectangle[m + 5];
for (int i = 0 ; i < m ; i++) {
string[] te = Console.ReadLine().Split();
a[i].bian = int.Parse(te[0]);
a[i].len = Math.Max(int.Parse(te[1]) , int.Parse(te[2]));
a[i].wid = Math.Min(int.Parse(te[1]) , int.Parse(te[2]));
}
Array.Sort(a , 0 , m , new MyComparer());
Console.WriteLine(a[0].bian + " " + a[0].len + " " + a[0].wid);
for (int i = 1 ; i < m ; i++) {
if (a[i].len == a[i - 1].len && a[i].wid == a[i - 1].wid && a[i].bian == a[i - 1].bian)
continue;
Console.WriteLine(a[i].bian + " " + a[i].len + " " + a[i].wid);
}
}
}
}
}